GIMP 2.5.2 – wersja rozwojowa

GIMP 2.5.2 – wersja rozwojowa

przez -
3 371
GIMP

Wydana została wersja rozwojowa programu graficznego – GIMP. Wydanie oznaczone numerem 2.5.2 zawiera nowy, przebudowany interfejs użytkownika. Jest on bardziej wygodny od swego poprzednika. Wydanie 2.5.2 pokazuje jakie nowości czekają nas w wersjach 2.6 a następnie 3.0.

Programiści zmienili bibliotekę obsługującą przestrzenie barw z GDK na GEGL (Generic Graphics Library). Obsługuje ona takie przestrzenie jak RGB, CIELab, YCbCr, a każdy kanał koloru określany jest z precyzją od 8 do 32 bitów.

Aplikacja została przygotowana do zmian jakie pojawią się w nadchodzącym wydaniu biblioteki GTK+. Wydanie 2.5.2 zawiera również narzędzie do zaznaczania obszaru opisanego wielokątem. Inne zmiany to:

  • dodanie dokowalnego (zakotwiczalnego) okna dialogowego do zarządzania ustawieniami narzędzia Kolor
  • ulepszenie przycisku skalowania w oknie popup
  • zaznaczenie środka prostokątów/ograniczonych prostokątów podczas przenoszenia
  • dodanie okna dialogowego dla zapytań podręcznika użytkownika online
  • dodanie możliwości mapowania dynamiki twardości dla narzędzia Gumka
  • dodanie funkcjonalnego gimp-remote dla systemu Windows
  • zablokowanie domyślnego kompilowania i instalowania narzędzia gimp-remote
  • dodanie możliwości przesuwania za granice obrazu
  • dodanie nowej funkcji PDB: gimp-palette-get-colors
  • dodanie wyszukiwarki tekstowej w Przeglądarce Pomocy
  • poprawki i czyszczenie kodu

Źródło: gimpuj.info.

  • Ja chcę obrazki :D !

  • Próbowałem skompilować bo sam jestem ciekawe. Niestety utknąłem na:

    <pre>(lt-gegl:20425): GLib-GObject-WARNING **: invalid uninstantiatable type `<invalid>' in cast to `GeglTileHandler'

    **

    ** ERROR:(gegl-buffer.c:532):gegl_buffer_constructor: assertion failed: (backend)

    /bin/bash: line 1: 20425 Aborted GEGL_DEBUG_TIME=yes GEGL_SWAP=RAM GEGL_PATH=../../operations ../../bin/gegl clones.xml -o `echo clones.png | sed s?./??` > `echo clones.png | sed s?./?? | sed -e s/png/txt/`

    make[5]: *** [clones.png] Błąd 134

    ./OpenRaster-00.xml</pre>

  • tomko222

    Mi się udało skompilować ale się wysypuje przy próbie uruchomienia :(