Gnash 0.8.8 ze wsparciem VA-API i 100% kompatybilnością YouTube

Gnash 0.8.8 ze wsparciem VA-API i 100% kompatybilnością YouTube

    przez -
    2 352
    Open Source
    Nie tak dawno informowaliśmy o wydaniu Lightspark – Wolnym i Otwartym odtwarzaczu flash, który poczynił ogromne postępy z takimi cechami, jak LLVM używające silnika JIT, wsparcie dla uruchamiania wtyczek poza głównym procesem przeglądarki Firefox, oraz usprawnienia renderowania. Projekt poczynił również ogromne postępy, dzięki wsparciu społeczności i Fundacji Wolnego Oprogramowania.

    Twórcy Gnash 0.8.8 deklarują nam 100% zgodność z wideo umieszczanym na YouTube.  Ponadto dodano możliwość przełączania się podczas pracy pomiędzy silniki renderujące Cairo, OpenGL i AGG. Cairo dodatkowo wspiera wiele różnych back-endów renderujących oraz eksperymentalny back-end DRM, w celu wsparcia OpenGL ES. Natomiast dzięki możliwości zmieniania pomiędzy FFmpeg i Gstreamera, można odtworzyć praktycznie każde wideo, czy dźwięk.

    Dzięki integracji odpowiednich patchy: Nvidia VDPAU i AMD XvBA w celu obsługi VA-API (Video Acceleration API), użytkownicy procesorów graficznych: Intel Clarkdale/Arrandale (Core i3/i5 ze zintegrowanym GPU) z ostatnim wsparciem DRM VA-API, własnościowe sterowniki Nvidia z VA-API front-end, sterowniki AMD/ATI Catalyst z VA-API front-end, grafiki Pulsbo i S3 ze wsparciem VA-API mogą od teraz odtwarzać wideo w Gnash z użyciem VLD, iDCT, Motion Compensation, i Deblocking dla formatów MPEG-2/MPEG-4 ASP/H.263/H.264/VC-1/WMV3, wykorzystując po części procesor graficzny, razem z CPU.

    Warto zaznaczyć, iż Adobe Flash Player wspiera dekodowanie z wykorzystaniem GPU jedynie na systemach Windows i Mac OS X, jednakże bez wsparcia VA-API, jak i VDPAU. Dodatkowo Gnash działa bardzo dobrze na 64 bitowej platformie Linux.

    Gnash 0.8.8 można pobrać z  GnashDev.org.

    Podobne artykuły

    Open Source

    przez -
    15 388
    Open Source

    przez -
    0 237
    Open Source

    przez -
    2 277
    • pioruns

      W tej chwili w Debianie jest gnash 0.8.9~git20110220-1 i YouTube na nim nie działa, nie da się otworzyć żadnego filmiku.

      Dopóki YT nie działa na gnashu, to mało kto będzie tego używać na Linuksie. Ja sam też tego nie będę rusząć, póki nie zrobią działającego YT.

    • Pingback: Kongoni 1.12.3 (Cicero) | OSWorld.pl()