I-Nex 0.5.4 z EDID, Makefile oraz łatkami dla openSUSE

I-Nex 0.5.4 z EDID, Makefile oraz łatkami dla openSUSE

przez -
4 306
Sprzęt
Michał Głowienka ogłosił wydanie I-Nex 0.5.4, aplikacji która podaje nam szczegółowe informacje o zainstalowanych podzespołach komputerowych. Informacje w I-Nex wyświetlane są w osobnych zakładkach. Aplikacja potrafi generować raport i wysyłać go na serwisy typu nopaste, raportować błędy na launchpad przez apport oraz posiada możliwość zrobienia zdjęcia aktualnej zakładki. Pojawiły się osobne wersje aplikacji w pakietach deb, dla architektury x86 oraz amd64, ze względu na elementy kodu pisane w C.

  • Dodano możliwość wykrywania modelu, serii oraz daty produkcji monitora, podłączonego przez złącza: HDMI, VGA, DVI i DisplayPort. Jest to robione za pomocą EDID (Extended display identification data). Decyzja o dołączeniu kodu edid-decode do I-Nex zapadła przez wzgląd na ilość pakietów, jakie I-Nex ma w zależnościach. Zamiast wymagać edid-decode zainstalowanego w systemie, I-Nex sam zawiera go w sobie jako inex-decode.
  • Utworzono plik Makefile, który zastąpił złożony debian/rules
  • Instalacja odbywa się poprzez utworzenie pakietu DEB, za pomocą debuild lub make, make install
  • Zostały także zaadoptowane łatki dla openSUSE.

W kolejnych wersjach spodziewać się można rozbudowania systemu raportów oraz GUI dla wszystkich informacji zawartych w EDID.

Instalacja w systemie

Do uruchomienia I-Nex będą nam potrzebna dwa repozytoria PPA: ppa:nemh/gambas3 oraz ppa:i-nex-development-team/stable.

add-apt-repository ppa:nemh/gambas3
add-apt-repository ppa:i-nex-development-team/stable
apt-get update
apt-get install i-nex

  • Gość

    Program wygląda zachęcająco ale nie mogę go zainstalować gdyż mam za starą wersję biblioteki gambas.
    Nie mogę zaktualizować gambasa z powodu błędów z zależnościami.
    Natomiast instalując jakąkolwiek starszą wersję I-Nexa kompatybilną z wersją gambasa w moim systemie wywala mi błędy i nijak nie jestem w stanie jej sprawdzić.

    PS. Zawsze instalując cokolwiek korzystającego z gambasa mam problemy i z reguły jak tylko widzę że z tego korzysta to sobie daruje.
    Jak widać ten przypadek nie jest odosobniony.

    • eloaders

      Jak widać autor wpisu zapomniał dodać ppa gambas3.
      kilka dni temu wyszedł gambas 3.5
      Wrzucając paczkę na launchpad, buildd korzysta z pakietów potrzebnych do kompilacji z innego ppa i wtedy kompiluje I-Nex z użyciem najnowszej wersji Gambas3 i niemożliwym jest uruchomienie I-Nex gdy w systemie jest zainstalowana starsza wersja.

      Dodaj to repo https://launchpad.net/~nemh/+archive/gambas3 i powinno być po problemie lub skompiluj ze źródeł z użyciem obecnie zainstalowanej wersji w systemie.