NetBSD 7.0 z ogromną ilością nowości

NetBSD 7.0 z ogromną ilością nowości

przez -
7 1660
NetBSD
Ogłoszono wydanie systemu NetBSD 7.0. Dodano pełną akcelerację graficzną na kartach graficznych Intel HD i AMD Radeon, z wykorzystaniem wolnych sterowników graficznych. Pojawiła się obsługa wieloprocesorowych systemów komputerowych ARM. Sporo pracy włożono we wsparcie nowych minikomputerów: Raspberry Pi 2 Model B, ODROID-C1, BeagleBoard, BeagleBone, BeagleBone Black, MiraBox, Cubieboard2, Cubietruck, Banana Pi, Kobo Touch, Netwalker, Parallella, ZedBoard. Dodano obsługę nowych procesorów: Allwinner A20, Allwinner A31, Freescale i.MX50, Freescale i.MX51, Xilinx Zynq.

Dokonano sporo ulepszeń w filtrze pakietów NPF warstwy trzeciej. W podsystemie USB pojawiła się obsługa wieloprocesorowych systemów komputerowych. Dodano nowego demona – blacklistd, który integruje filtry pakietów, aby dynamicznie ochraniać inne demony sieciowe, takie jak sshd, named, ftpd. Dodano obsługę GPT w sysinst poprzez rozszerzenie menu partycjonowania. Pojawiły się skrypty Lua. Dodano GCC 4.8.4, dzięki czemu zaimplementowano standard C++11. Naprawiono sporo błędów.

Podobne artykuły

  • o_O

    Meh, nie ma screenshotów.

    • gosc

      sh, vi, gcc i zużycie RAMu przez system plików, tu nie ma co zrzucać. To jest dopiero budulec do zrobienia sobie dobrego systemu. Bo potem można to skonfigurować na sieciowy magazyn danych z połączeniem terminalowym po porcie szeregowym do celów diagnostycznych, jak i na stację graficzną z najnowszym KDE i obsługą 3 monitorów.

  • Kamil Koczurek

    “zaimplementowano standard C++11” To NetBSD jest tak bardzo w tyle? Cóż, i tak idzie im lepiej, niż tym od Hurda. :P

    • BSDfan

      Rozwiń myśl.

    • Kamil Koczurek

      Co tu rozwijać? To chyba żart, że w obsługa C++11 pojawia się w 2015r.

    • o_O

      “GCC 4.8.4, which brings support for C++11”
      Obsługa C++11 w GCC:
      https://gcc.gnu.org/projects/cxx0x.html

    • BSDfan

      Jak napisał o_O tu chodzi o obsługę C++11 wprowadzoną przez GCC 4.8, które znalazło się teraz w systemie bazowym w NetBSD 7.0.
      Do pkgsrc GCC 4.8 trafiło praktycznie zaraz po jego wydaniu w 2013r.