NeteXt’73 Kernele v29.3 z usuniętym błędem CVE-2014-0196

NeteXt’73 Kernele v29.3 z usuniętym błędem CVE-2014-0196

    przez -
    2 276
    NeteXt'73
    Projekt NeteXt’73 ogłosił wydanie Kerneli v29.3, które są oparte o jądro Linux 3.14.3. Jądra są przeznaczone dla Ubuntu 12.04, Ubuntu 12.10, Ubuntu 13.04, Ubuntu 13.10 i Ubuntu 14.04 w wersjach 64 bitowych. Wraz z nimi dostarczane są odpowiednio przystosowane do działania sterowniki nVidia Linux Display Driver oraz AMD Catalyst. Kernele posiadają auto-grupowanie (Automatic process group scheduling), używają dwóch planistów: CFQ (dla dysków zwykłych) i noop (dla dysków SSD) oraz wyłączono SELinux.

    Nowa wersja zawiera bardzo wiele zmian, w tym: sekcja USB, multimedia, systemy plików oraz architektura ARM. Przebudowano podstawowe narzędzia, jakie są wykorzystywane w procesie optymalizacji i budowy Kerneli, co poprawiło jakość kodu wynikowego, zwiększyło wydajność i responsywność.

    Usunięto także błąd opisany jako: CVE-2014-0196. Luka to w sprzyjających warunkach pozwalała na przejęcie konta administratora na atakowanej maszynie, ale można ją było wykonać jedynie lokalnie.