OpenBSD 5.3 z demonem SMTPD 5.3

OpenBSD 5.3 z demonem SMTPD 5.3

    przez -
    5 501
    OpenBSD
    Stuart Henderson ogłosił wydanie OpenBSD 5.3 Blade Swimmer, nowej wersji systemu BSD, znanego ze swoich wysokich zabezpieczeń, dzięki skrupulatnemu przeglądaniu kodu. Dodano sporą liczbę nowych sterowników i obsługiwanego sprzętu, a także udoskonalono stos sieciowy. Kod OpenSMTP 5.3 jest wreszcie stabilny i gotowy do zastosowań produkcyjnych.

    OpenBSD 5.3

    OpenSMTPD jest demonem implementującym protokół SMTP, który odpowiada za dostarczanie wiadomości na lokalnej maszynie lub do innych serwerów SMTP. Aktualna stabilna wersja była w fazie rozwojowej od końca 2008 roku i jest częścią projektu OpenBSD. Autorami kodu są Gilles Chehade, Eric Faurot i Charles Longeau.

    Dodano również demona npppd dla protokołów L2TP, L2TP/IPsec, PPTP, PPPoE. Udoskonalono bezpieczeństwo w postaci użycia Position Independent Executables (PIE) oraz udoskonalenia Stack Smashing Protection (SSP) w kompilatorze GCC (Debian, IBM).

    Z pakietów znajdziemy:

    • GNOME 3.6.2
    • KDE 3.5.10
    • Xfce 4.10
    • MySQL 5.1.68
    • PostgreSQL 9.2.3
    • Postfix 2.9.6
    • OpenLDAP 2.3.43 i OpenLDAP 2.4.33
    • Firefox 3.6.28 i Firefox 18.0.2
    • Thunderbird 17.0.2
    • GHC 7.4.2
    • LibreOffice 3.6.5.2
    • Emacs 21.4 i Emacs 24.2
    • Vim 7.3.154
    • PHP 5.2.17 i PHP 5.3.21
    • Python 2.5.4, Python 2.7.3 i Python 3.2.3
    • Ruby 1.8.7.370 i Ruby 1.9.3.392
    • Tcl/Tk 8.5.13 i Tcl/Tk 8.6.0
    • JDK 1.6.0.32 i JDK 1.7.0.11
    • Mono 2.10.9
    • Chromium 24.0.1312.68
    • Groff 1.21
    • Go 1.0.3
    • GCC 4.6.3 i GCC 4.7.2
    • LLVM i Clang 3.2
    • Xenocara (X.Org 7.7 z X.Org Server 1.12.3 + łatki, FreeType 2.4.11, fontconfig 2.8.0, Mesa 7.11.2, xterm 287, xkeyboard-config 2.7 i więcej)
    • GCC 4.2.1 (+łatki), GCC 3.3.6 (+ łatki) i GCC 2.95.3 (+ łatki)
    • Perl 5.12.2 (+ łatki)
    • Apache 1.3 ze wsparciem SSL/TLS i DSO, specjalnie zabezpieczona wersja
    • Nginx 1.2.6 (+ łatki)
    • OpenSSL 1.0.1c (+ łatki)
    • SQLite 3.7.14.1 (+ łatki)
    • Sendmail 8.14.6, z libmilter
    • Bind 9.4.2-P2 (+ łatki)
    • NSD 3.2.15
    • Lynx 2.8.7rel.2 ze wsparciem HTTPS i IPv6 (+ łatki)
    • Sudo 1.7.2p8
    • Ncurses 5.7
    • Heimdal 0.7.2 (+ łatki)
    • Binutils 2.15 (+ łatki)
    • Gdb 6.3 (+ łatki)
    • Less 444 (+ łatki)
    • Awk 10 sierpnia 2011 roku

    • Pan Łukasz

      GNOME 3.6 i KDE 3.5. Ale asymetria w traktowaniu środowisk graficznych… Pewnie podyktowane jest to względami bezpieczeństwa, w końcu OpenBSD to najbezpieczniejszy system operacyjny na świecie. Coś więc musi być z ich punktu widzenia nie tak z obecnym KDE w tej dziedzinie.

      • Nicram

        Kiedyś bardzo mocno bylem w klimaty OpenBSD zagnieżdżony. Takie różnice w wersjach środowisk czy pakietów w ogóle wynikają głównie nie z bezpieczeństwa, ale z braku programistów, którzy by robili porty po prostu. Kodujących na ten system jest mało w wyniku czego część aplikacji jest po prostu stara.

      • Pan Łukasz

        Być może problemem jest też GNU/Linux-ocentryzm, który niestety podobno występuje we wiodących wolnych programach. Ludzie od OpenBSD narzekają na to zjawisko. Może po prostu w KDE jest tak dużo zależności od GNU/Linux-owej infrastruktury, że przy dosyć małych zasobach ludzkich trudno efektywnie opiekować się takim oprgramowaniem.