SparkyLinux 4.2 z wieloma aktualizacjami i porządkami pakietów

SparkyLinux 4.2 z wieloma aktualizacjami i porządkami pakietów

    przez -
    1 1543
    SparkyLinux
    Paweł Pijanowski ogłosił wydanie SparkyLinux 4.2 LXDE, MATE, Razor-Qt i Xfce. System jest w pełni kompatybilny z Debian Testing Stretch (repozytoria z dnia 15.12.2015 roku). Dodano jądro Linux 4.2.0, Enlightenment 0.20.0 (pakiet 0.20.1 dostępny jest w repozytorium), KDE Plasma 5.4.3, LXDE 0.99.0-2, LXQt 0.10.0-2, MATE 1.10.2, Openbox 3.6.1-2, Xfce 4.12.2, Iceweasel 38.2.1esr, Icedove 38.4, LibreOffice 5.0.4 rc1, Wine 1.8 rc3. Usunięto pakiety KDE/KWin i od teraz system używa tylko menadżera okien Openbox i aplikacji bazujących na bibliotekach Qt oraz GTK (edycja LXQt). Domyślny instalator otrzymał wsparcie dla SDDM (edycja KDE), dzięki czemu zaznaczenie opcji “autologin” pozwala na aktywację automatycznego logowania w systemie.

    Reszta zmian:

    • Usunięto narzędzie minstick, a w jego miejsce dodano Sparky USB Live Creator. Jest to graficzna nakładka dla polecenia dd oraz nowy pakiet Sparky USB Formatter
    • Usunięto pakiet boot-repair
    • Wtyczka xfce4-mixer została zastąpiona przez pulseaudio-plugin (edycja Xfce)
    • Dodano: TOR Messenger, małą aplikacja “Pierwsze Uruchomienie Sparky”, pakiet menulibre (edycja Xfce) oraz nowe menu generowane za pośrednictwem “obmenu-generator” oraz “xfdashboard” (edycja Openbox)
    • Przetłumaczono na różne języki narzędzia sparkowe
    • Usunięto wszystkie stare tapety, a domyślna tapeta została lekko zmodyfikowana, w zależności od edycji Sparky
    • Posprzątano i usunięto zbędne pakiety

    Przeprowadzono ankietę, która miała na celu ustalenie popularności różnych wersji. Z tego powodu zawieszono dalsze rozwijanie JWM i CLI. Większość narzędzi SparkyLinux zostało przekonfigurownych i używają teraz własnych plików językowych. Wszystkie, jakie do tej pory udało się usprawnić o tę funkcję, używają lokalizacji polskiej lub angielskiej. Dzięki pomocy społeczności niektóre z nich posiadają już lokalizacje w innych wersjach językowych.

    Użytkownicy edycji Enlightenment (e19) powinni zapoznać się ze sposobem aktualizacji do wersji e20: linuxiarze.pl/enlightenment-0-20/.

    • Pawel Jaworski

      Bardzo fajnie, że jest wersja LXQt, nie ma zbyt dużo dystrybucji z tym środowiskiem a robi się z niego bardzo fajny zamiennik dla KDE – przy okazji lżejszy i stabilny. Można by jedynie popracować nad wyglądem trochę :) Takie moje sugestie do twórców:
      1. Skoro to LXQt a nie LXDE to może Exaile zastąpić Clementine? ;)
      2. Płyty CD/DVD odchodzą w zapomnienie, czy warto dodawać Xfburn do obrazu płyty?